To search
You are here : Linux > Linux > Communications > ppp 2.4.7

ppp 2.4.7

Freedownload8 rating:
License:
GPL (GNU General Public License)
Added:
Nov 30, -1
Submit date:
Feb 14, 2015
Publisher:
Paul Mackerras
File size:
Downloads:
410
 

ppp 2.4.7

by Paul Mackerras

ppp (also known as Paul's PPP Package) is an open source command-line software project designed from the ground up to implement the PPP (Point-to-Point Protocol) technology on any GNU/Linux operating system, as well as on the Solaris OSes.

Can be used to dial out an ISP

Not that many Linux or computer users, for that matter, use dial-up Internet connection anymore, but ppp can be used to dial out an ISP (Internet Service Provider) using the “pppd call apex” command. However you will need to configure the /etc/ppp/peers/apex file before you can actually use the application.

I want to see some example!

Using the above command to start a dial-up connection from your Linux box, you will have to add the following lines to your /etc/ppp/peers/apex file:

ttyS0 38400 crtscts
connect '/usr/sbin/chat -v -f /etc/ppp/chat/apex'
defaultroute
user softpedia
remotename apex

The software also contains a chat script located at /etc/ppp/chat/apex, which can look like this:

ABORT "NO CARRIER"
ABORT "NO DIALTONE"
ABORT "ERROR"
ABORT "NO ANSWER"
ABORT "BUSY"
TIMEOUT 90
REPORT CARRIER
"" at
OK "atw1&d0&c1"
OK
atdt62485791
"~"

In addition, if you Internet service provider user PAP authentication, you will have to set up your /etc/ppp/pap-secrets file like this:

# Secrets for authentication using PAP
# client    server      secret                  IP addresses
softpedia        apex    "notmypassword"

Is this tool really useful?

The short answer is no, if you connect to the Internet using a fiber optic T1 line and your ISP doesn't uses modems. Otherwise, you will need to install the ppp (Point-to-Point Protocol) package to dial your ISP from your GNU/Linux or Solaris box. The software is available for download as a universal source archive, but it can be easily installed from the default software repositories of your operating system.

Languages:

OS requirements for ppp 2.4.7:

  • Download ppp 2.4.7

User comments about ppp 2.4.7

Comment ppp 2.4.7

  1. What did you think of the program?

    Log in or Create Account to post a comment.
         
    *
    *
  2. Rate this software    
  1. Security Code: Captcha Image Change Image

Get Our News, Everywhere

Popular searches

Linux

Communications